Delay in Settlement – OBN Global Limited

Incident Report for Cardstream

Resolved

OBN Global Limited has received the delayed settlement file from its supplier, and it was processed at 5am.

As a result, transactions authorised on Wednesday 2 April will now settle to merchants one day later.

OBN Global apologises for this delay.
Posted Apr 04, 2025 - 09:34 BST

Monitoring

OBN Global Limited has been notified by an underlying supplier that they are unable to provide Scheme and Interchange fee data today to OBN.

The result will be a knock-on one-day delay in settlement to merchants of OBN Global.

OBN Global apologise for this delay.
Posted Apr 03, 2025 - 16:58 BST
This incident affected: OBN.