Delayed OBN Global settlements to merchants

Incident Report for Cardstream

Resolved

OBN Global has resolved the incident that delayed Card and Open Banking settlements to merchants on Wednesday 26 August.

OBN Global will settle delayed funds to merchants as part of their normal settlement cycle.

Please note, that as per Bank Holidays, merchants on daily settlement may receive a delay in settlement due to OBN Global not receiving funds from Card issuers. This is operationally normal, and not related to the resolved incident above.
Posted Aug 27, 2026 - 13:10 BST

Investigating

OBN Global is currently investigating an issue that has delayed processing and settlements to merchants. As this is an active incident, OBN Global will provide an update later. OBN Global apologises for any delay.
Posted Aug 27, 2026 - 10:44 BST
This incident affected: OBN.