3-D Secure Pit Server

Incident Report for Cardstream

Resolved

Full 3-D Secure Pit Server availability has now returned.

Our engineers continue to monitor.
Posted May 15, 2026 - 16:28 BST

Identified

Cardstream is currently investigating the intermittent availability of the 3-D Secure Pit Server.

Please note this is a test environment and does not affect production 3DS transactions.
Posted May 15, 2026 - 13:16 BST
This incident affected: Cardstream Payment Gateway.