Delay in Settlement Processing - WorldPay
Incident Report for Cardstream
Resolved
This incident has been resolved.
Posted Nov 15, 2024 - 11:10 GMT
Identified
We have identified an issue with a number of Worldpay transactions from yesterday.
As a result, there may be a delay in the settlement of funds for the affected transactions.
Posted Nov 14, 2024 - 11:31 GMT
This incident affected: Cardstream Payment Gateway.